Menu disappeared after updating theme

Home Forums Jevelin Theme Menu disappeared after updating theme

Home Forums Jevelin Theme Menu disappeared after updating theme

Viewing 20 posts - 1 through 20 (of 22 total)
  • Author
  • RaskFin
    Participant

    hi!

    we updated Jevelin to the latest theme after updating UNYSON (which caused the page builder to fail). We fixed that by updating everything. But now the menu on our site has disappeared. The menu structure is still place in the appearance and I can see the header. But none of the links appear.

     

    http://Www.raskfinance.com

     

    Please help!

    RaskFin
    Participant

    More info:

    • It is a mobile issue only (desktop works fine)

    Hi @RaskFin,

     

    Sorry to hear of the problem you are having.

     

    I can see you are using older version of theme on your shared site so please update it to the following latest version.

     


    Please login to access this file

     

    Best regards,
    Shufflehound team

    Also please make sure to use latest version of Unyson plugin and update its extensions as described in the following topic.

     

    https://support.shufflehound.com/forums/topic/unyson-update-breaks-theme/#post-10097

    RaskFin
    Participant

    Hi Shufflehound,

    Thank you for your speedy reply.

     

    I have the latest theme and Unyson plugin installed (please see screenshot).

    • Jevelin 2.5
    • Unyson 2.7.6

     

    Attachments:
    You must be logged in to view attached files.

    I could confirm the issue on your site but it is working fine on my test site.

     

    This can be due to plugin conflict on your site so please try temporary deactivating all plugins except Unyson plugin and see whether everything works fine and then enable the plugins one by one to see which plugin is conflicting if any.

    RaskFin
    Participant

    Hi Shufflefound,

    I did as you requested and deactivated every plugin except Unyson. I even tried uninstalling Unyson. Still, it has the same issue.

    Could it a setting I have wrong? I did not change anything during the update to 2.5.0 but maybe something was added by mistake?

    Please try using recently released 2.5.1 theme version.

    RaskFin
    Participant

    Hi Shufflehound,

    That did not work.

    If you say the test site is okay and it isn’t our plugins, nor Unyson, could it have something to do with the menu links? Or the fact it is running on multisite?

    *the problem is the same across all subdomains*

     

    I have tried creating a new menu but I got the same result.

    It is going on 5 days now without a mobile menu, so we really need to find the bug as soon as possible.

    I’m not suggesting it is a Shufflehound problem but we did nothing other than update the Jevelin theme and Unyson, and we are agreed it is not the plugins.

    So it is very frustrating.

    Thanks again!

     

    RaskFin
    Participant

    I think I may have worked something out. A Bootstrap shortcode plugin may have been interfering.

     

    I have not found a solution, as can be seen:

    https://www.raskfinance.com/

     

    Perhaps it is a security issue?

    I’m lost with this problem.

     

     

    Hello. I have the latest theme build but I don’t have a mobile menu as well. Can you help me?

    @RaskFin @evgenyvasenev

    To troubleshoot the issue on your site could you please also share me your site FTP or cPanel details along with site admin login details?

    RaskFin
    Participant

    Hi Shufflehound,

    Thank-you. I have updated your user login details via private message.

    RaskFin
    Participant

    Hi @evgenyvasenev,

    Sorry to hear you are experiencing the same problem. At least, now, we are not the only one with the problem.

    I’m not sure if this will apply to you but we are running a multisite subdomain network and the menu does not work across any of our sites.

    After deactivating all of our plugins I am not sure if it is a plugin which caused the conflict, although it may be a party to the problem. That is, updating the theme may have caused the conflict. I’m happy to share a list of our plugins or any questions you have if it means we can figure this out sooner!

    Goodluck.

    Sent privately.

     

    Solution for this topic

    @RaskFin I troubleshooted ot on your site and found out this is happening because your web host flywheel is caching old theme script file https://t47d6yx2bm-flywheel.netdna-ssl.com/wp-content/themes/jevelin/js/scripts.js?ver=1.0

     

    You can compare it with new theme file here https://www.raskfinance.com/wp-content/themes/jevelin/js/scripts.js

     

    So please contact your web host to clear old cache so that new theme file will be cached.

    @evgenyvasenev Currently your shared site is not accessible for me so please make sure you are using latest version of theme and clear all the cache.

    Solution for this topic

    Thanks, it was cache.

    RaskFin
    Participant

    Thanks, Shufflehound.

    I’m in contact with my host. And I will report back here once it has been resolved. As it stands I have flushed the cache but it has not worked, so I will get to the bottom of it with them.

    Thanks again

    RaskFin
    Participant

    Hi Shufflehound. See private message.

Viewing 20 posts - 1 through 20 (of 22 total)