woocommerce + ultimate members breaks naviagation menu dropdown

Home Forums Jevelin Theme woocommerce + ultimate members breaks naviagation menu dropdown

Home Forums Jevelin Theme woocommerce + ultimate members breaks naviagation menu dropdown

Viewing 20 posts - 1 through 20 (of 22 total)
  • Author
    RESOLVED Posts
  • hi,

    i’ve been using jevelin for a few weeks with ultimate members without issue.  i installed and enabled woocommerce today, and the navigation menu drop downs stopped appearing.  i activated other themes with all of my plugins active and the drop downs appear as expected, but not when i have jevelin activated.  i disabled all plugins and left ultimate members and woocommerce active and still no dropdowns appeared.  when i disable either ultimate members or woocommerce, then the dropdowns appear normally.  seems like an issue with jevelin and the combination of ultimate members / woocommerce.

     

    any ideas what the trouble might be, or how to fix?

    thanks!

    Hi @CopyrightSlap,

     

    Sorry to hear of the problem you are having.

     

    We are facing this type of issue first time so Would you mind if i log in to your site and do some troubleshooting? If this is ok then could you please share me your site log in details privately by adding them in the box having text “Click here to share private content. Only you and forum moderators will be able see it.”?

     

    Best regards,
    Shufflehound team

    Thank you for the offer on looking under the hood, but we do not feel comfortable giving someone other than us access to the site.

     

    In addition, we have found that the Cart Page in woommerce seems to have significant css or formatting issues, showing images extremely out of the correct dimensions.

     

    We have tested with other themes and menus and woocommerce are unaffected in those themes with both plugins turned on.

     

    We were under the impression that woocommerce would work with Jevelin out of the box. It was a main reason we purchased the theme. Is there a workaround, or would it be possible to reverse the purchase?

     

    Thank you.

    The theme works fine with WooCommerce and you can test it on our below demo site.

     

    https://jevelin.shufflehound.com/

     

    Could you please share me the pages URLs from your site where it is not displaying correctly so that i can troubleshoot it?

    Hi. The same thing happens to me (Jevelin+Woocommerce+UM), I also use the Ultimate Member plugin and in previous versions I never had any problems. I use the Header 6 (side navigation) and the menu button stops working, it does not open anymore. Other plugins also fail, such as Instagram Feed. I have tried to disable all the puglins one by one and this happens only when your theme, woocommerce and eUltimate Member are active. I do not know what to do.

    I visited your shared site and saw this happens because of the javascript error message generated by following Ultimate Member plugin file as shown in the attached screenshot so please contact the plugin developer to resolve this javascript error.

     

    /ultimate-member/assets/js/um-scripts.min.js

    Attachments:
    You must be logged in to view attached files.

    I posted in the UM forum to see about a response. That said, we have tested with UM and WooCommerce on non-Jevelin themes and everything works. So it seems like it may be a clash of the Javascript, but given that it works with other themes (we are currently testing with the free “Brilliance” theme), could it be an error in Jevelin’s scripts with how it interacts with UM? If so, is there any chance there is a workaround within Jevelin? We love the theme, we just need to have site functionality.

    As we can’t access your site to troubleshoot the issue, could you please share us the ultimate members plugin so that I can troubleshoot it on my test site?

    Ultimate Member plugin (free): https://ultimatemember.com/

    I used below latest version of theme along with latest versions of WooCommerce plugin and free version of Ultimate Member plugin but I couldn’t reproduce the issue.

     


    Please login to access this file

     

    The drop down menu works fine for me as shown in the attached screenshot.

     

    Do I have to configure any plugin settings to reproduce the issue?

     

    Attachments:
    You must be logged in to view attached files.

    i’ve entered the install settings from ultimate members in the private information field below.  it should have some helpful info as far as our configuration.  thanks for the help.  the settings list our enabled plugins, but the issue still exists when they’re all disabled, and the only enabled plugins are UM and Woo commerce.

    Thank you for sharing the details.

    I will see whether I can reproduce the issue using shared details but it should be really helpful if anybody share me their site temporary access.

    Any progress on the solution? @omartin — any chance you are able to share access to your site to the developer?

     

    I saw there was a Unyson update to extensions, I’m not sure if that might change things, let us know. As we do not have full functionality with Jevelin at present we are using a different temp theme that gives us functionality, hoping the Jevelin issue can be resolved and we can go back to Jevelin. Would love love love a fix on this.

    We couldn’t reproduce the issue yet so It would be helpful if anybody shares their site temporary access.

    I have reproduced the issue on an alternate site. See Private field for contact info for me to send login.

    Attachments:
    You must be logged in to view attached files.

    @CopyrightSlap Thank you for sharing the site details but it seems you missed to share password of site so that I can log in to your site.

     

    Please share me all site login credentials.

     

    Also to resolve menu issue please try adding the following CSS code in the Custom CSS code option of your theme on the below path.

     

    Admin Area -> Appearance -> Theme Settings -> Custom Code -> CSS Code

     

    .sh-nav li.menu-item:hover .sub-menu {
        display: block;
    }

    Thank you. I will try the CSS. There will still be an issue with the WooCommerce plugin as it displays irregularly, especially when a product is selected, certain buttons are missing and the product image either does not display or is disproportionately large.

     

    As I wrote in the last post, please email the email address I left in the private box for the site login credentials. I am not posting access to my site directly online, even if it is in a private box.

    That CSS makes the sub-menus appear (ALL of the sub- and sub-sub-menus under a tab all at once), BUT then you cannot actually click on the menu item. When you move down to click on the sub-menu item, they all disappear.

     

    It does work on my temp site (without sub-sub-menus), but on our main site, the menus still remain unfunctional. There is something deeper at heart.

     

    Please email to the email I included in the private message for me to send credentials for full fix.

    I am going to build out the test site more to give more to work with.

     

    Please email the email address I listed so I can send you the site credentials to solve this issue. We would very much like it fully resolved ASAP.

     

    Thank you.

    You can send an email on support2@shufflehound.com and notify us here.

Viewing 20 posts - 1 through 20 (of 22 total)