Background color not working

Home Forums Jevelin Theme Background color not working

Home Forums Jevelin Theme Background color not working

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    RESOLVED Posts
  • I have changed the background color on theme settings to an almost pitch black (#111111), but every page I make has the background color set to white.

     

    The only solution I found so far is to manually set every section color to black, but I’d like to solve that in case another person has to add some new content to the site.

    Hi @alesnora,

     

    I hope you are well today and thank you for your question.

     

    Could you please share me your site URL where it’s happening so that i can troubleshoot it?

     

    Best regards,
    Shufflehound team

     

    I have manually set all the section colors to the one I wanted, but you can see through the animation that the “official” background is white:

     

    http://www.fenachamp.com.br

    You can change its color by adding the following CSS code in the Custom CSS code option of your theme on the below path.

     

    Admin Area -> Appearance -> Theme Settings -> Custom Code -> CSS Code

     

    #page-container .fw-page-builder-content {
        background: #111111;
    }

    Worked for the first page, but every new page I make continues to be white.

     

    Example: http://www.fenachamp.com.br/a-fenachamp/

    Solution for this topic

    Please also use below custom CSS code to make it work.

     

    #page-container .sh-section,
    #page-container .content-container.sh-page-layout-default {
         background: #111111;
    }
    

    It’s working now. Thank you.

    Ok but this change doesn’t allow me to change the color of specific sections, everything is set to black even the ones I wanted to be in a different color.

    Then instead of above CSS code try using below custom CSS code.

     

    #page-container .content-container.sh-page-layout-default {
         background: #111111;
    }

    Nope, still white.

    Do you mean on the page http://www.fenachamp.com.br/a-fenachamp/ ?

    This is because you have applied white color on the section.

     

    As you don’t want to apply back color on all the sections therefore we changed the code and now you have to set appropriate color on each sections.

    If it is not feasible for you and if you have few sections where you want to change section color from black then we can apply black color globally to each sections and then change specific section color developing custom CSS code.

    Yeah the code didn’t work as I wanted to, I wanted to set some sections to white and some to black, while maintaining the background black

    I fixed most pages manually, my only problem right now is with an accordeon I’ve set here: http://www.fenachamp.com.br/historia-fenachamp/

    It has this weird white border and black background and I can’t fix it manually.

    Solution for this topic

    To fix its color please use below custom CSS code.

     

    #page-container .sh-accordion .panel-body {
        background-color: #FFF !important;
    }
    
    #page-container .sh-accordion .fw-page-builder-content{
         background-color: #FFF !important;
    }

    that works, thanks

    You are most welcome here 🙂

    Hi,

     

    I am having the same problem, looking for a more elegant solution.

     

    It appears that by default, the “.content-container” class adds a “background-color: #fff;”.

     

    Setting the body background color in the theme settings always gets overridden by the .content-container background color.

     

    How can I make the .content-container class have no background color set by default? This way, the body background color will show, and where I do need a custom background color, I can set it with the Unyson drag and drop builder.

     

    Thanks

     

Viewing 16 posts - 1 through 16 (of 16 total)