Body compose not applied

Home Forums Jevelin Theme Body compose not applied

Home Forums Jevelin Theme Body compose not applied

Viewing 20 posts - 1 through 20 (of 22 total)
  • Author
    RESOLVED Posts
  • See attached images but on single product, my home page header is not transparent/position absolute when loaded.

    It looks like this CSS is not applied anymore

    body:not(.compose-mode) .sh-header-builder-main-above-content, body.page.compose-mode .sh-header-builder-main-above-content {
    position: absolute;
    top: 0;
    left: 0;
    right: 0;
    z-index: 240;
    }
    I don’t know why and how fix it. I checked and my shortcode.css still has this piece of code.

    • This topic was modified 3 weeks, 1 day ago by vatfr.
    • This topic was modified 3 weeks, 1 day ago by vatfr.
    Attachments:
    You must be logged in to view attached files.

    Hi @vatfr,

     

    I hope you are well today and thank you for your question.

     

    You can achieve this by editing that page and setting its header to light as described in the below topics.

     

    https://support.shufflehound.com/forums/topic/transparent-header/#post-2187

     

    Best regards,
    Shufflehound team

    vatfr
    Participant

    Hi,

    Even when I switch to Light header it doesn’t work. (I just made the change to light you can check it on the URL)

    Also it seems when I click on page update my choice is not saved? cf screenshot after I click on update.

    Attachments:
    You must be logged in to view attached files.

    Please try changing the header layout of the page to any built-in layout.

     

    If you have upgraded to the redux framework then please try deactivating the Unyson plugin.

    vatfr
    Participant

    Just changed to header 8 and it shows it on my Home page. But still not preselected in the page settings. And still no success with Light Header.

    Have you tried deactivating the Unyson plugin?

     

    Would you mind if I log in to your site and do quick troubleshooting? If this is ok then could you please temporarily create an admin user account and share the account login details privately by adding them in the box having text “Enter your private content here (only you and forum moderators will be able to see it)”?

    Done.

    But I don’t use Unyson plugin. I moved to Redux and uninstalled Unyson.

    • This reply was modified 2 weeks, 6 days ago by vatfr.

    I could confirm the page settings not getting saved issue on my test site, therefore, I notified the theme developer about this so that it will be fixed.

     

    The issue will be fixed ASAP.

     

    The transparent header only works for the built-in header templates and not for the custom header templates created using WPBakery page builder.

     

     

    How can I switch back to the original transparent header then?

    Does it mean I won’t be able to add languages, change logo, etc?

    What do you mean by “original transparent header”?

     

    The header displays transparent on your website now.

     

    Please advise.

    I mean the original header from theme here: https://jevelin.shufflehound.com/single-product/

    I removed the below custom CSS code from your website and it started displaying the same.

     

    body:not(.compose-mode) #page-container .sh-header-builder-main-above-content {
        position: static;
    }
    

    Oh thanks a lot. I added this CSS in order to have it to work again indeed. But it didn’t and I forgot about it.

    Thanks for your help. Problem solved.

    One last question actually. I think there is a visual bug on this header (dark version)

    https://jevelin.shufflehound.com/single-product/shop/

    It does a bump with the width when it doesn’t on the one used on the Home page?

    Also when you say “I could confirm the page settings not getting saved issue on my test site, therefore, I notified the theme developer about this so that it will be fixed.”

    Do you have a bug report so I can follow the fix? This is really annoying because every time I make a change on my page, it resets the header 🙁

    May I ask which header did you use on the Home page? When I select “Fashion Shop Header Light” which should be the correct one as per your design, it is not the correct one on my Home page…

    I’m getting a bit annoyed that my header changes are not saved permanently and breaks every time I update something else in my page…

    • This reply was modified 2 weeks, 3 days ago by vatfr.

    The bug related to the page setting is not getting saved will be resolved soon and you will be notified here after resolving it.

    Solution for this topic

    The issue is fixed in the below latest version of the theme so please update the theme as described here https://support.shufflehound.com/updating-theme/

     


    Please login to access this file

    Fix works great, but now I can’t have the theme demo header to work like you did before on my site.

    The one from single product: https://jevelin.shufflehound.com/single-product/

    I have set it again by editing the Page Settings of the home page as shown in the attached screenshot.

    Attachments:
    You must be logged in to view attached files.
Viewing 20 posts - 1 through 20 (of 22 total)