Google Maps Not Showing

Home Forums Jevelin Theme Google Maps Not Showing

Home Forums Jevelin Theme Google Maps Not Showing

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    RESOLVED Posts
  • I’ve added the content element to my homepage, and have entered the API in the theme settings as well as the element.  Address added and nothing showing.

    Attachments:
    You must be logged in to view attached files.

    Hi @samv,

     

    I hope you are well today and thank you for your question.

     

    This seems happening on your site because Google API is not configured correctly which is generating the below error message https://developers.google.com/maps/documentation/javascript/error-messages#referer-not-allowed-map-error as shown in the attached screenshot so please configure it correctly as instructed.

     

    The current URL loading the Google Maps JavaScript API has not been added to the list of allowed referrers. Please check the referrer settings of your API key on the Google API Console.

     

    Best regards,
    Shufflehound team

    Attachments:
    You must be logged in to view attached files.

    Thank you I added that, and now it says its an “expired version” of the API.

    Attachments:
    You must be logged in to view attached files.

    I can see still the existing error RefererNotAllowedMapError is displaying on your site so please resolve it.

    I don’t understand whats happening.  The URL has been added in Google API and everything appears set up correctly .

     

     

    Attachments:
    You must be logged in to view attached files.

    Please try adding domain without forward slash and if you still get the error then please contact Google support centre as this can be your host issue.

    Solution for this topic

    Ok I found what the issue was.  The domain needs to be correct in 2 areas in the Google API Console.  Not only in the domain verification (which it already was correct), but also under the API key settings itself.

     

    My domain was not working when the “www.” was included.  I removed it, and the map started working.

     

     

    Attachments:
    You must be logged in to view attached files.

    Awesome great to see you got that resolved.

     

    Please advise if you have more questions.

     

    Have a fantastic day!

Viewing 8 posts - 1 through 8 (of 8 total)