RTL support

Home Forums Jevelin Theme RTL support

Home Forums Jevelin Theme RTL support

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
  • How can I change the theme (the basic one) into RTL support without changing language in WordPress Admin Pannel?

    I don’t quite sure that you’ve understood me. I mean I did notice that there is option in “theme options” to enable RTL for the site, but it enables it partially, so my question is how can I enable it (not partially but for icons and menu) without changing the wp-admin language to some RTL language?

    It is working fine for the menu on my test site and not sure which icons you are referring so could you please tell me a bit more in detail about this by sharing screenshots of it and page URL where it is displaying?

    Please take a look at the screenshot below.

    Logo should be on the left side.

    V sing on each menu item should be on the left side (like in submenu) of the label not on the right side as it’s now.

    Moreover look at the Social Networks Icons/Search Icon which are too close to the menu.

    Attachments:
    You must be logged in to view attached files.

    I’ve tried to install jevelin-child theme, when I did it it’s broken all the styles including RTL style now it doesn’t display as it should on RTL. It also replaced all colors/setting which I’ve set before.

     

     

     

    Please take a look at the screenshot below.

    Logo should be on the left side.

    V sing on each menu item should be on the left side (like in submenu) of the label not on the right side as it’s now.

    Moreover look at the Social Networks Icons/Search Icon which are too close to the menu.

    You are using language right to left in your shared screenshot  so the elements are displaying in opposite direction that is Right to Left.

     

    I’ve tried to install jevelin-child theme, when I did it it’s broken all the styles including RTL style now it doesn’t display as it should on RTL. It also replaced all colors/setting which I’ve set before.

    Please share the screenshots of the issue and also the page URL where it is displaying as requested previously.

     

     

    You are using language right to left in your shared screenshot  so the elements are displaying in opposite direction that is Right to Left.

    So how can I change this behavior, because this is not what’s meant to be?

    Just disable RTL support from theme options as shown in the attached screenshots.

    Attachments:
    You must be logged in to view attached files.

    Yes but this prevents the whole page to be RTL compatible. I mean another way to do this .

    I am note sure what you are trying to achieve here.

     

    Do you want whole site to support RTL except header?

     

    Please advise.

     

    Do you want whole site to support RTL except header?

    Yes and no. I need the whole site to support RTL including menu but I need the logo and the menu to change places (logo on the left and menu on the right side).

    Ok so you want to customize the RTL support functionality.

     

    To achieve this we have to develop custom CSS code.

     

    Could you please share me your site URL where it’s displaying so that i can help you to achieve it?

    I’ve sent you URL as PM message.

    You can achieve it by adding the following CSS code in the Custom CSS code option of your theme on the below path.

    Admin Area -> Appearance -> Theme Settings -> Custom Code -> CSS Code

     

     

    
    .sh-header .sh-table-cell:first-child {
        float: right !important;
    }
    .sh-header .sh-table-cell {
        float: left !important;
    }

    Doesn’t work.

    It is working fine for me when i use it in browser inspector.

     

    I visited your shared site but didn’t see the shared code anywhere.

     

    If you are using any cache on your site like autoptimize then after using the CSS code please clear the cache and also the browser cache.

    I think this is the problem. I’d added the code, then I’ve cleared the cache and I still can’t see the css code that has been added.

    Then please temporary disable the autoptimize cache plugin on your site.

Viewing 19 posts - 1 through 19 (of 19 total)