style.css in Jevelin Child doesn't work

Home Forums Jevelin Theme style.css in Jevelin Child doesn't work

Home Forums Jevelin Theme style.css in Jevelin Child doesn't work

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    RESOLVED Posts
  • Hello,

     

    I tried to use the style.css in the Jevelin Child Theme to add some larger amounts of CSS code, but it doesn’t work. The code is being ignored.

     

    It works when I use the custom code field for css in the theme settings, but from what I understand this is only supposed to be for smaller changes to the css.

     

    Do you have any explanation why the style.css might not work?

     

    Best regards

    Stefan

    Hi Stefan,

     

    I hope you are well today and thank you for your question.

     

    I have tested it on my test site and it is working fine for me.

     

    Could you please share me your child theme along with the custom CSS code so that i can troubleshoot it on my test site?

     

    Best regards,
    Shufflehound team

    Hello,

     

    I would like to do that, but how do I share my child theme with you?

     

    Best regards

    Stefan

    Use following plugin to download it and then attach it to your reply here to share it.

     

    https://wordpress.org/plugins/download-plugins-dashboard/

    Hello,

    thank you for the hint. I have attached the child theme to this post. The CSS code is below:

     

    .sh-404 {
    background:#fff;
    color:#3f3f3f;
    }

    .sh-404-title {
    text-align:left;
    font-size: 30px;
    padding: 20px 0;
    line-height:40px;
    color:#3f3f3f;
    }

    .sh-404-text {
    display:block;
    width:100%;
    text-align:left;
    padding: 10px 0 5px 0;
    color:#3f3f3f;
    }

    .sh-404-text-spacing {
    margin:10px 0;
    }

    .sh-404-search-form {
    display:block;
    width:100%;
    text-align:left;
    color:#3f3f3f;
    }

    .sh-404-search-field {
    height:32px;
    width:350px;
    }

    .sh-404-search-submit {
    background-color: #c10525;
    border: none;
    color: white;
    text-align: center;
    text-decoration: none;
    display: inline-block;
    font-size: 16px;
    padding: 3px 10px;
    -webkit-transition-duration: 0.4s;
    transition-duration: 0.4s;
    }
    .sh-404-search-submit:hover {
    background-color:#b1b2b3;
    }

    Attachments:
    You must be logged in to view attached files.

    The codes seems correct and the CSS code should work on your site.

     

    Could you please share me your site URL where you are using the CSS code and tell me what you want to style so that i can troubleshoot it?

    Hello again,

     

    The site is in maintenance mode, so if I send you the link it won’t work. A while ago, I sent you login credentials which are still valid for you to access the backend and frontend despite the maintenance mode. Do you still have access to those login details? The URL is sachjournal.blog and the css code is for the 404 error page.

     

    Please note that the css code is not currenlt you the style.css file of the child theme, as this didn’t work for me. It is rather in the Custom Code CSS in the Theme Settings. You would have to copy the code in question to style.css please.

     

    Best regards

    Stefan

    I have added CSS code from Custom CSS option of theme in to your child theme style.css file and it seems working fine for me.

     

    Could you please clear your browser cache and tell me now what is not working for me?

    Hello,

     

    The same problems still occurs. After you copied the CSS code into the style.css file, it was both in the style.css and in the custom code field of the the theme settings. When I deleted the code from the custom code fields in the theme settings, the css from the style.css file is not being recognized. I did clear my cache and even tested it on another computer; and both times it did not work for me.

     

    Best regards

     

    Stefan

    Not sure where you are testing it but it is working fine for me on the page https://sachjournal.blog/kontakt/ as shown in the attached screenshot.

    Please tell me specifically where it is not working by sharing page URL and screenshot.

    Attachments:
    You must be logged in to view attached files.

    Solution for this topic

    You are right, it works for me now. I am not sure why it wasn’t working before.

    Glad it is working fine for you now 🙂

Viewing 12 posts - 1 through 12 (of 12 total)