Update Main Theme (using child-theme)

Home Forums Jevelin Theme Update Main Theme (using child-theme)

Home Forums Jevelin Theme Update Main Theme (using child-theme)

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
  • I’ve installed main-theme 2.4.0 and after that I’ve installed child-theme and activated it.

    Now I see that you’ve updated the main theme to the 2.4.1 version.

     

    When I update it do I need to activate it?

    I mean if I do activate it will I need to activate the child theme again after that?

     

    How can I update it now (when I use child-theme) and might it change some of my settings?

    O.K. I’ve installed/updated (using “Easy Theme and Plugin Upgrades” plugin) main-theme 2.4.1 (without activating it).

     

    I’ve tried to set Form’s style as the style 5 (the new one), it doesn’t display form fields at all only the text above the fields (take a look at the screenshot below).

     

    Moreover, now I have problems with Recaptcha (“ReCAPTCHA couldn’t find user-provided function: fw_forms_builder_item_recaptcha_init“) It is not displayed as you can see it on the screenshot below.

    Attachments:
    You must be logged in to view attached files.

    Hi @Konrud,

     

    Sorry to hear of the problem you are having.

     

    I have tested it on my test site and it’s working fine for me using latest version of Jevelin theme as displayed in the attached screenshot.

     

    Could you please share me the page URL from your site where it is not displaying correctly so that i can troubleshoot it?

     

    Best regards,
    Shufflehound team

    Attachments:
    You must be logged in to view attached files.

    I’ve sent you URL of the site (as a PM) you can see it on the main (HOME) page.

    Please note that Recaptcha disappears every time I made some changes to the form.

    Please let me know when you finished.

    The form fields borders are not dispalying because of the CSS code border-width: 0px used on your site in the following custom CSS code snippet. To resolve the issue please remove this CSS property from below CSS code.

     

    #contact-form-469453acb8dcdfc36366173424965d9f.contact-form input, #contact-form-469453acb8dcdfc36366173424965d9f.contact-form textarea {
        text-align: left;
        border-radius: 25px;
        padding: 29px 30px;
        border-width: 0px;
    }

    Regarding displaying recaptcha could you please tell me whether it displays when you do not use RTL support?

     

     

    The form fields borders are not dispalying because of the CSS code border-width: 0px used on your site in the following custom CSS code snippet

    I don’t know what is this. This isn’t my code I didn’t put any custom code for the #contact-form-469453acb8dcdfc36366173424965d9f.contact-form.

    Regarding displaying recaptcha could you please tell me whether it displays when you do not use RTL support?

    It doesn’t matter, each time I do some changes on the form settings (e.g. set minimum characters on the input field….) Recaptcha disappears.

    Solution for this topic

    I don’t know what is this. This isn’t my code I didn’t put any custom code for the #contact-form-469453acb8dcdfc36366173424965d9f.contact-form.

    If you don’t find it then add the following CSS code in the Custom CSS code option of your theme on the below path.

    Admin Area -> Appearance -> Theme Settings -> Custom Code -> CSS Code

     

    div#page-container #content .contact-form input,
    div#page-container #content .contact-form textarea {
        border-width: 1px;
    }

     

     

    It doesn’t matter, each time I do some changes on the form settings (e.g. set minimum characters on the input field….) Recaptcha disappears.

    I could confirm the issue on my test site and this is the issue of Unyson plugin builder so we can’t resolve it. The plugin developer will resolve the issue but not sure when.

     

    You can either create the whole form first and then add recaptcha later so that no changes will be made in the form or use the form provided by following Contact form 7 plugin.

     

    https://wordpress.org/plugins/contact-form-7/

    https://wordpress.org/plugins/google-no-captcha-recaptcha/

    If you don’t find it then add the following CSS code in the Custom CSS code option of your theme on the below path.

    Admin Area -> Appearance -> Theme Settings -> Custom Code -> CSS Code

     

    div#page-container #content .contact-form input,
    div#page-container #content .contact-form textarea {
        border-width: 1px;
    }

     

    This code solves it partially. First of all, it also adds border to the submit button

    so you need to add ( :not([type=submit]) )

     

    ........ .contact-form input:not([type=submit]),
    div#page-container #content .contact-form textarea {
        border-width: 1px;
    }

    Moreover, it still doesn’t display labels above the input fields not using style 2 nor using styles 3,4,5.

    I can see the contact form labels on your site as shown in the attached screenshot.

     

    Please advise.

    Attachments:
    You must be logged in to view attached files.

    That’s because I’ve changed the form style.

    Sorry, but I can’t wait for you, I have work to do.

    I can’t have my site with the ugly form without proper style.

    Ok not an issue. Please advise if you have more questions.

    I don’t quite understand is there any chance you’ll fix this issue (including labels for the form)?

    I went in to the theme code to troubleshoot it and actually found out it is a part of theme contact form styles which is performed by the following codes.

     

    if( isset($atts['style']) && $atts['style'] == 'style2' ) : ?>
    				#contact-form-<!--?php echo esc_attr( $atts['id'] ); ?--> label {
    					display: none;
    				}
    
    
    #contact-form-<!--?php echo esc_attr( $atts['id'] ); ?-->.contact-form input,
    				#contact-form-<!--?php echo esc_attr( $atts['id'] ); ?-->.contact-form textarea {
    					text-align: left;
    					border-radius: 25px;
    					padding: 29px 30px;
    					border-width: 0px;
    				}

     

    So, what are you trying to say by that?

    You’ve hidden form’s labels deliberately?

    In code excerpt that you’ve shown,

    I don’t see any mention about form style 5 but only style 2.

    And let me remind you that we’re talking about issue with form style 5 .

    So, what are you trying to say by that?

    I am again telling you that it is a part of theme contact form styles.

     

    You’ve hidden form’s labels deliberately?

    Yes

     

    In code excerpt that you’ve shown,

    I don’t see any mention about form style 5 but only style 2.

    And let me remind you that we’re talking about issue with form style 5 .

    I have only shared you small code part of style2 as it is large code so i didn’t share all the code of all styles but if you want to see it then you can in the theme file /jevelin/framework-customizations/extensions/forms/extensions/contact-forms/shortcodes/contact-form/static.php

Viewing 17 posts - 1 through 17 (of 17 total)