With the latests updates all elements with position: sticky aren't working

Home Forums Jevelin Theme With the latests updates all elements with position: sticky aren’t working

Home Forums Jevelin Theme With the latests updates all elements with position: sticky aren’t working

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • marcolys
    Participant

    Dear developers team,

    I’m a WP plugins developer and have noticed that from your latests updates all the elements I assign css property “position: sticky” aren’t working, they just act with “relative” property.

    Before 5.0 they were working fine.

    Can you please give it a check?

    Thanks

    Hi @marcolys,

     

    I hope you are well today and thank you for your question.

     

    Could you please share the page URL from your site where it is not working and tell me exactly on which element you are applying the sticky position so that I can troubleshoot it?

     

    Best regards,
    Shufflehound team

    marcolys
    Participant

    Hi, thanks for your quick reply.

    this is the page: https://www.dalbellomoto.it/cerca/

    The element with sticky property is the search button, as I told you, sticky was working fine previous your 5.* updates and it’s working fine on all the other themes I’ve tried (WP default themes, Astra, OceanWP and more).

    This is the button with his wrapper:

    <li class="form_button clear li-button-search">
    <button type="submit" value="" class="amcore-add-loader"><span><strong class="conteggio-risultati-mezzi">42 Risultati</span></button>

    This is the class:

    .sw-advanced-search-form .form_button, .sw-sidebar .form_button {
    position: -webkit-sticky;
    position: sticky;
    bottom: 50px;
    z-index: 100;
    }

    I have other elements using css sticky property and none of them are working.
    The only ones I’ve managed to make them working are the ones I’m using jQuery fixto plugin.

    Thanks

    • This reply was modified 2 months ago by marcolys.

    You can resolve the issue by adding the following CSS code in the Custom CSS code option of your theme on the below path.

     

    Admin Area -> Jevelin -> Theme Settings -> Custom CSS/JS -> CSS Code

     

    html, 
    html body {
        overflow: visible !important;
    }

    marcolys
    Participant

    Great, it works!

    I suggest to add this as default rule in the next updates as other plugins i’m using had the same issue, one of them are Gtranslate, now the issue is also fixed on that one.

    Thanks

    Sure, we will consider it if it does not break any other functionality.

Viewing 6 posts - 1 through 6 (of 6 total)