Contact Form Fail - Admin-Ajax.php

Home Forums Jevelin Theme Contact Form Fail – Admin-Ajax.php

Home Forums Jevelin Theme Contact Form Fail – Admin-Ajax.php

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    RESOLVED Posts
  • I have a contact form on my website: http://hailpern.net/joshua2017/ and when i try to use it, it fails (see first image).

     

    In the console i get (see second image).

     

    I also attached images of my contact form.  Clicking the “send test email” works in the UI, but does not send a test email.

    Attachments:
    You must be logged in to view attached files.

    Hi @cmurockstar,

     

    I hope you are well today and thanks for posting here.

     

    I could confirm the issue on your shared site and it is happening because the contact form script is using wrong URL http://hailpern.net/wp-admin/admin-ajax.php instead of http://hailpern.net/joshua2017/wp-admin/admin-ajax.php

     

    Have you installed WordPress in sub directory?

     

    We are troubleshooting the issue to fix it and will update you here ASAP.

     

    Best regards,
    Shufflehound team

    yes – the way my hosting is set up, is that every wordpress is in a subdirectory.

     

    * though some sites I purchase an additional domain and map it onto that directory (and tell the wordpress that it is that new domain instead). But i am not doing that for this site yet

    We are working on this issue to resolve and will update you here soon.

    any news on this issue?

    Thanks for your patience here, we are still working on this issue.

    For your reference – i have remapped my subdomain, so now the website is at joshua.hailpern.com

    Ok. Thank you for notifying.

    Hi,

     

    I am also having AJAX error on contact form, It still sends me the email but it displays the ajax error box. My site is not in a sub directory. Any ideas?

    Also it seemed random at start now its constant. Have kept up-to-date with all theme updates also I am using the child theme.

    Home

    I sent test message on your shared site using contact form displayed on the homepage but i didn’t get any error message as shown in the attached screenshot.

     

    Could you please share the screenshot of error message that you are getting?

    Attachments:
    You must be logged in to view attached files.

    That picture is from my website…

    Hi there,

     

    If you have issues with our standard contact form element, then the fastest way to fix it could be by using our other supported contact form. It is one of the most popular contact form plugins and it should give you plenty options.

    Thank you for letting us know. 🙂

    Hi cmurockstar,
    I have the same issue with contact form and admin-ajax.php.
    I’ve installed and configured Postman SMTP [all fine, sending emails].
    But still contact form is generating Ajax 404 error.
    Have you done any other configuration of contact form to make it all work back again?

    Many thanks in advance for you help!

    Cheers,
    Marcin

    Hi Marcin,

     

    No i didn’t do anything else. I installed postman. got that working 100% with google/gmail API.  send method is wp-mail that is it.

    Hello, thanks a lot your reply.
    Still I have 404 errors. Contact Form 7 works fine, so strange thing.
    I will go then with other contact form plugin.

    @marciotoledo This is old topic and to help us keep support thread separates could you please create your own thread for your question here instead of replying on others thread as it makes the thread messy and hard to read.

     

    If you want to you can also add reference of this thread in your newly created thread.

     

    We would be more than happy to help you on your new thread.

Viewing 19 posts - 1 through 19 (of 19 total)