Contact Form Settings don't stay saved

Home Forums Jevelin Theme Contact Form Settings don't stay saved

Home Forums Jevelin Theme Contact Form Settings don't stay saved

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    RESOLVED Posts
  • Dear support team,

     

    it is great working with your great theme! thank you!

     

    I am having trouble with the contact Form and I hope you can help me:

    Setting up the form and putting in the Settings (SMTP) works fine so far and I am receiving the test Email.

    However, each time I am saving the Configuration and Update the Site, the Settings disappear, which means, the Setting fields are empty again.

    I am then getting an Ajax Error in my Browser console. Please see screenshot attached.

     

    I would appreciate to get help with this.

    Thank you very much!

    Attachments:
    You must be logged in to view attached files.

    Hi @aufregend,

     

    Sorry to hear of the problem you are having.

     

    Could you please try using latest version of theme from http://support.shufflehound.com/download/jevelin-beta/

     

    If you face the issue with latest version of theme then could you please tell me a bit more details about reproducing the issue as i can’t reproduce it just saving the contact form settings?

     

    Best regards,
    Shufflehound team

    Dear Shufflehound Support,

     

    I did download and install your latest beta version. Unfortunately, I am still getting the ajax error.

    • so now my Contact Form -> Settings -> Mailer Options do stay saved.
    • But when I hit the “Submit” Button on the website, I am getting an error message: “Ajax error (more details in console)”
    • Please see the page with contact form – you can try filling out:
      http://praxis-leitner.de/wordpress/kontakt/
    • see screenshot with error message attached

    Thanks again for looking into this!

    Attachments:
    You must be logged in to view attached files.

    Your shared contact form page is not publicly accessible so i need your site login details to access it.
    Could you please send the login details on support2@shufflehound.com and then reply on this topic to notify me?

    Hey I have the same error here http://patryksmakosz.com/tasty/wp-admin/

    I provided the details on the support2@shufflehound.com

    Additional error. I lost my homepage, and a day of development. Without any reason, I just lost my whole homepage – developed locally. Only thing I found was some leftovers in the database…. I have few years of wordpress development behind me and it’s first time I ever met with something like this.

    I saved my work day before and in the morning I woke up with no homepage, my friend,  developer was also amused. So please investigate it.

    Only thing I could tell you as a hint – I added some portfolio item, clicked publish, and closed my laptop – maybe I interrupted the process of saving to database, but that shouldn’t affect nothing more than that post.

    To solve this contact form issues as fast as possible we can recommend you to use Contact Form 7 plugin, which is compatible with our theme and have many great options and output should look very similar. We will try to solve this issue, but we didn’t developer our basic contact form element, therefore it is harder for us to fix it.

     


    @Dikus
    We will investigate it. Can you please tell us if the issue was in one homepage like page or the whole site got corrupted?

    Hi, yup I thought the contact form isn’t yours, just wanted to check – maybe this was something simple 🙂

    As it goes for that wierd error. I’ve been using the “home:basic” template from your demo. Only thing that got corrupted was the homepage (where I did everything 🙂

    I’ve been sticking some of your designs from different templates using the Unyson save template option.

    Usually wordpress stores info about the site – I’ve updated that site like 60 times, so some older versions should be available, at least should be visible in the database.

    I found in my pages > trash an mysterious “no title” page which was the newest deleted item – all of my items had a title so that was a bit strange. After restoring that, sadly there were no rollback.

    In the database I found 3 fresh records with content matching my vanished homepage content – they were also without a title,  but at least I could copy html markup – sadly Unyson does not accept that markup, so I have to build everything from the ground

    Thank you for letting us know.

    This looks like Unyson page builder related issues, but at the moment we are not sure. We will make some testing and create a fix if possible.

     

    Other thing about this issue – Unyson page builder stores its data in posts meta fields, therefore it is possible that this information is still available in your database, just somehow got separated.

    Now there’s another problem, with WPML

    Versions checked
    sitepress-multilingual-cms.3.6.3
    sitepress-multilingual-cms.3.6.2
    sitepress-multilingual-cms.3.5.1.1

    Throw the same error

    Besides that it ate my image from about section tho the image was in the library.

    I’m starting to feeling very unpleasant…

    <b>Fatal error</b>: Uncaught exception ‘Exception’ with message ‘Error upgrading schema for table “icl_languages”: ‘ in /home/patryksm/public_html/tasty/wp-content/plugins/sitepress-multilingual-cms/inc/upgrade-functions/upgrade-3.3.7.php:54 Stack trace: #0 /home/patryksm/public_html/tasty/wp-content/plugins/sitepress-multilingual-cms/inc/upgrade.php(151): include_once() #1 /home/patryksm/public_html/tasty/wp-content/plugins/sitepress-multilingual-cms/inc/upgrade.php(121): icl_upgrade_version(‘3.3.7’) #2 [internal function]: icl_plugin_upgrade(”) #3 /home/patryksm/public_html/tasty/wp-includes/class-wp-hook.php(298): call_user_func_array(‘icl_plugin_upgr…’, Array) #4 /home/patryksm/public_html/tasty/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(”, Array) #5 /home/patryksm/public_html/tasty/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #6 /home/patryksm/public_html/tasty/wp-settings.php(326): do_action(‘plugins_loaded’) #7 /home/patryksm/public_html/tasty/wp-config.php(89): require_once(‘/home/patryksm/. in <b>/home/patryksm/public_html/tasty/wp-content/plugins/sitepress-multilingual-cms/inc/upgrade-functions/upgrade-3.3.7.php</b> on line <b>54</b>

    We can understand you, but this doesn’t look like a theme related issue, please check this in Google, there are lot of complains about this exact issue with WPML plugin.

     

    We found one possible solution here.

    Thanks, God that was harsh, stupid wpml.

    I had to use this solution

    https://wpml.org/forums/topic/activation-of-wpml-multilingual-cms-not-possible/

    And for me I had to start installing WPML from version 3.0, now it looks good.

    Thanks, keep up the good work 🙂

    Also this can help someone…
    https://wpml.org/forums/topic/when-trying-to-access-wpml-i-get-this-sorry-you-are-not-allowed-to-access-this/

    o fix this, I suggest you run the following snippet:
    <div class=”sh-wrapper”>
    <div>
    <div id=”highlighter_94509″ class=”syntaxhighlighter php”>
    <table border=”0″ cellspacing=”0″ cellpadding=”0″>
    <tbody>
    <tr>
    <td class=”gutter”>
    <div class=”line number1 index0 alt2″>1</div>
    <div class=”line number2 index1 alt1″>2</div>
    <div class=”line number3 index2 alt2″>3</div>
    <div class=”line number4 index3 alt1″>4</div>
    <div class=”line number5 index4 alt2″>5</div>
    <div class=”line number6 index5 alt1″>6</div></td>
    <td class=”code”>
    <div class=”container”>
    <div class=”line number1 index0 alt2″><code class=”php keyword”>function <code class=”php plain”>wpmlsupp_1706_reset_wpml_capabilities() {</div>
    <div class=”line number2 index1 alt1″><code class=”php spaces”>    <code class=”php keyword”>if <code class=”php plain”>( function_exists( <code class=”php string”>’icl_enable_capabilities’ <code class=”php plain”>) ) {</div>
    <div class=”line number3 index2 alt2″><code class=”php spaces”>        <code class=”php plain”>icl_enable_capabilities();</div>
    <div class=”line number4 index3 alt1″><code class=”php spaces”>    <code class=”php plain”>}</div>
    <div class=”line number5 index4 alt2″><code class=”php plain”>}</div>
    <div class=”line number6 index5 alt1″><code class=”php plain”>add_action( <code class=”php string”>’shutdown’<code class=”php plain”>, <code class=”php string”>’wpmlsupp_1706_reset_wpml_capabilities’ <code class=”php plain”>);</div>
    </div></td>
    </tr>
    </tbody>
    </table>
    </div>
    </div>
    </div>
    Just add the above code in your theme’s functions.php file (between the <?php and ?> tags) and visit once the front-page.
    Then you can remove this snippet.

    Thank you for letting us know. 🙂

Viewing 12 posts - 1 through 12 (of 12 total)