Empty space at top of content

Home Forums Gillion Theme Empty space at top of content

Home Forums Gillion Theme Empty space at top of content

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    RESOLVED Posts
  • Dear support team,

     

    I’ve done what was asked in the ‘Before creating a new topic’ but unfortunately the problem persists.

     

    Whenever I create a new post and use Visual Composer (or King Composer) to add content, after publishing or previewing, a blank space shows up at the top of the content -> see picture.

     

    When using Visual Composer I can make it go away by setting the margin and padding of a section to 0px; but I’d like to know how I can prevent this from happening without having to set the margin and padding manually every time I ,or someone else, creates a post.

     

    Feel free to login and see for yourself. I’ve turned back on a few plugins now, but turned them all off with the exception of Unyson and Visual Composer and the problem persisted. It doesn’t happen if you don’t use Visual Composer; however my blogging partner doesn’t know any HTML or CSS and so I will need Visual Composer to work.

     

    Look forward to your solution!

     

    Best,

     

    Ryan

     

    Attachments:
    You must be logged in to view attached files.

    Hi @SarahS,

     

    I hope you are well today and thank you for your question.

     

    You can remove that empty space by adding the following CSS code in the Custom CSS code option of your theme on the below path.

     

    Admin Area -> Appearance -> Theme Settings -> Custom Code -> CSS Code

     

    .post-content-share:not(.post-content-share-side):not(.post-content-share-mobile) {
        width: 55px;
    }

     

    Best regards,
    Shufflehound team

    You guys are fantastic! Thank you, it worked like a charm!

     

    Best,

     

    Ryan

    We always feel happy to help you and you are always welcome here 🙂

    Sorry to bother you guys (or girls) again.

     

    I thought the issue was resolved (it has partially) but some pages still have the same issue.

     

    When I ‘Inspect’ the website and ‘turn off’ the 80px, it works. Somehow the Custom CSS is not being picked up.

     

    I’ve tried adding !important; but that messes up the scrolling. I’ve also tried adding the piece of code in the Customization area; but that gives me the same scrolling issue.

     

    I don’t want to go into the actual stylesheet because it means that I would have to change the stylesheet with every update that comes along.

     

    Would you be able to help?

     

    Thanks in advance!

     

    Best,

     

    Ryan

    Could you please share me the page URLs from your site where it is still displaying so that i can help you to remove it?

    You’ll have to log in using the details provided in my original post  as it currently has a coming soon page up.

     

    The issue occurs on:

     

    https://chronolove.com/my-orange-monster-my-watch-you-pervert/

    https://chronolove.com/4-years-with-my-omega-speedmaster-professional/

     

    the width of the social share ‘bar’ is actually still 80px here as well, but somehow it doesn’t affect the content:

    https://chronolove.com/review-wolf-meridian-single-watch-winder/

     

    Best,

     

    Ryan

    Could you please try using below CSS code instead of above?

     

    .post-content-share:not(.post-content-share-side):not(.post-content-share-mobile) {
        width: 55px !important;
    }
    
    .post-item-single-container > div:first-child {
        position: absolute !important;
    }
    
    .post-item-single-container > div[style*="position: static"] {
        display: none !important;
    }

    That does remove the space at the top of the content!

     

    However, the social share ‘widget’ on the left doesn’t scroll smoothly anymore. Is there any way we can have both the space removed and the social share widget scroll smoothly as it normally does?

     

    Is it something with my content?

     

    Best,

     

    Ryan

    Yes it is working fine on my test site so it seems something wrong with your site.

     

    Please remove all custom CSS code that you are using on your site.

     

    This can be child theme issue on your site so to confirm it just temporary use the Sparkling theme instead of child theme on your site. If everything works fine then it’s your child theme issue.

     

    Also this can be due to plugin conflict on your site so please try temporary deactivating all plugins except Unyson plugin and see whether everything works fine and then enable the plugins one by one to see which plugin is conflicting if any.

Viewing 10 posts - 1 through 10 (of 10 total)