Featured Images Issues

Home Forums Gillion Theme Featured Images Issues

Home Forums Gillion Theme Featured Images Issues

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
  • I’m having some serious issues with featured images on my client website. I spent the last 12 hours trying to fix this problem and even hired 3 freelancers which were unable to fix the issue. I’m not sure what kind of black magic you guys added to the theme code, but whatever, maybe you guys can help me with this. (I know, I’m pissed off, I’m just raging).

    I’ll be leaving all the site credentials in private info field so I won’t waste time because my client is pissed off at me over this god damn featured images.

     
    <h2>The Issue</h2>
    My client wants the posts featured images to be displayed in portrait mode, like this https://prnt.sc/ilryr9  .  The already created posts featured images are displaying fine, as it should, in portrait mode, in normal quality. For some reason, recently, whenever I update a featured image or create a new post, the featured image gets completely distorted,  as seen here http://prntscr.com/ils3d9 . By inspecting the element, I noticed that the source image used is 1200×675 (http://prntscr.com/ils3z9) and the old ones that are working fine are   600×675 (http://prntscr.com/ils4os).

    How can I fix this? Make the new images not get stretched and display properly in 600×675 or in a resolution that displays in portrait? I tried Installing ,  uninstalling the Simple image sizes plugin but nothing changed at all.  Some my question is, how can I fix this?

     

    I really like the theme by the way, very clean and beautiful.

     

    Thank you

     

    Hi @tiagosimk,

     

    I hope you are well today and thank you for your question.

     

    I logged in to your site and found you are adding those images in the post content and the theme is not controlling their size at all.

     

    The images are displayed whatever size you have set them in the post as shown in the attached screenshots.

     

    Best regards,
    Shufflehound team

    Attachments:
    You must be logged in to view attached files.

    Yes, I forgot to mention that for the last 5 posts I had to do this manually and hide the featured image as a temporary fix. But take this post here as an example http://www.helenagasparetto.com.br/cookies-de-nutella/ .Thanks

    I can see on the shared post the featured image is displaying fine as shown in the attached screenshot so could you please tell me what is the issue with it?

    Attachments:
    You must be logged in to view attached files.

    Yes, for example on mobile , https://m.imgur.com/a/CEwP5 . Also, if you upload a new picture and set as featured, for some reason it gets stretched (you can try to create a demo post, set a featured image and click preview ( just please don’t publish). You will see it will be all messed up.

     

     

    Attachments:
    You must be logged in to view attached files.

    It seems the following CSS code used on your site was causing the issue.

     

    .single-post .post-thumbnail img {
        width: 100%;
        height: 720px;
        max-width: 540px;
        margin-left: auto !important;
        margin-right: auto !important;
    }

    I resolved it using the below custom CSS code on your site.

     

    .single-post .post-thumbnail img {
        height: auto !important;
        width: auto !important;
    max-width: 100% !important;
    }

     

    Could you please confirm it?

    Hi, For mobile now it displays fine, perhaps, for desktop it displays in a very big resolution compared to other images, excessive height and width, as seen here http://www.helenagasparetto.com.br/biscoitos-de-gengibre-e-mel-gingerbread-cookies and on my attatched image.

    Thanks

     

    Attachments:
    You must be logged in to view attached files.

    Ok I changes the above shared CSS code as following on your site so could you please check it now?

     

    .single-post .post-thumbnail img {
        height: auto !important;
        width: auto !important;
        max-width: 100% !important;
        min-width: 0 !important;
    }

    Hey there! It fixed the issues for older posts, but whenever I make a new post, and upload a image, it resizes to the landscape position, as seen the image below. This only affect if I make a new post and set a new featured image or if I edit  post and change the featured image. Thank you

    Attachments:
    You must be logged in to view attached files.

    For the old posts you are hiding featured images using temporary fix as stated above but for new posts you are displaying featured images therefore it displays with default featured image size which you can see on our demo site here https://gillion.shufflehound.com/2017/01/31/what-to-look-forward-in-2017-style-wise/

    Thanks for the reply, but i don’t think you understand. Yes, I did the temporary fix for some posts because it was broken before, but now it got fixed by you guys, all posts are showing ok. But, if I create a new post, they are shown in a wrong scale, you can login and make a draft and see what the featured image will look like, something far different from older posts.

     

    Do a test: Go here http://www.helenagasparetto.com.br/pumpkin-pie-torta-de-abobora-com-especiarias on WordPress admin and try to select a image from the gallery, can be any image (Just please only preview, don’t update). You will see that the updated image is in a totally different scale, landscape.

    Attachments:
    You must be logged in to view attached files.

    Please understand that default post featured image size is as following.

     

    https://gillion.shufflehound.com/2017/01/31/what-to-look-forward-in-2017-style-wise/

     

    The older posts on your site is displaying  featured image in different size because either they are not properly updated or you are using any custom solution to make this happen.

     

    Let’s find out the reason why your old images are displaying like that.

     

    First please disable all the Automatize and W3 Total cache on your site.

     

    Then use the below plugin to regenerate thumbnails.

     

    https://wordpress.org/plugins/force-regenerate-thumbnails/

    Oh nono, I don’t think you understand. I’m trying to make the new posts display like the old in portrait, I don’t want the same as the demo, I’m trying to make the new ones like the old ones, portrait. That’s what I mean. Sorry for the confusion.

    Yes I understood what you are trying to achieve but for that we need to understand why your existing old images are displayed in portrait so please do what I have told you above.

    Well, I think the reason is  because i’m using the custom css you provided me on early messages? I have disabled the cache . Again, my goal is to display all images on portrait. Old images are dispalying fine, new ones aren’t.

    It is not only about CSS. I will find it out.

     

    I can see you are using older version of Gillion theme on your site as shown in the attached screenshot so first update your theme to the below latest version of theme as described here https://support.shufflehound.com/updating-theme/

     


    Please login to access this file

    Attachments:
    You must be logged in to view attached files.
Viewing 16 posts - 1 through 16 (of 16 total)