Image size in 'About us' widget

Home Forums Gillion Theme Image size in 'About us' widget

Home Forums Gillion Theme Image size in 'About us' widget

This topic contains 10 replies, has 3 voices, and was last updated by  Shufflehound Support 1 month, 3 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    RESOLVED Posts
  • I use ‘Shufflehound About Us’ widget in the Blog page sidebar.

    I have set an image for that widget, and it uses 1024 x 978 size image, which is then scaled to 192 x 184. I get warnings about this in GTmetrix.

    Is it really necessary to use the largest size for a widget? Can I change it somehow? I wouldn’t like to upload another smaller image when I already have smaller versions of this one (200 x 200 or 150 x 140 for example).

    Hi @dellgirl,

     

    I hope you are well today and thank you for your question.

     

    Just download the exact size image that you want to display and rename it to any other name and set that image again in that widget.

     

    Best regards,
    Shufflehound team

    Eather I don’t understand something about using images, or you didn’t understand my question.

    When I upload an image to WordPress, it generates several resized versions of that image, some of them are WordPress and there are 8 resized Gillion’s versions. There are 14 versions in total (including original image).

    If I upload another, smaller image to be used in widget, I will have 14 more images which I don’t need.

    My question was:

    Why widget doesn’t use one of the existing smaller versions of the image?

    Like in the ‘Related posts’ section after the post content, for example.

    I can see in the theme file /gillion/inc/widgets/about-us/views/widget.php the following code added o line number 16 is displaying the large image, therefore I have notified the theme developer so that it will be changed to smaller image size.

     

    gillion_get_small_thumb( $atts['image']['attachment_id'], 'large' );

     

    In the meanwhile, please change the ‘large’ to any of the below values on your site.

     

    gillion-square-small

    gillion-square-micro-landscape

    gillion-portrait

     

    That is exactly what I have wanted, I just didn’t know where to change. 😉

    The ‘gillion-square-small’ is perfect, but maybe there should be optional.

    Thanks for the help.

    You are most welcome here 🙂

    Hello,

     

    I have a similar problem from pages, this is my ticket :

    https://support.shufflehound.com/forums/topic/image-size-on-page/

     

    Because you’r theme don’t use a best size for integrate a pictures in your modules.

    @guillaume_oriol You gave been replied in your new topic so you don’t need to post here.

    Solution for this topic

    We have added a new option in the About Us widget to select image size as shown in the attached screenshot. It is implemented in the below latest version of theme so please update the theme as described here https://support.shufflehound.com/updating-theme/

     


    Please login to access this file

    Attachments:
    You must be logged in to view attached files.

    It is working.

    Thank you

    You are always welcome here 🙂

Viewing 11 posts - 1 through 11 (of 11 total)