Featured images from all posts disappeared

Home Forums Gillion Theme Featured images from all posts disappeared

Home Forums Gillion Theme Featured images from all posts disappeared

This topic contains 9 replies, has 3 voices, and was last updated by  Shufflehound Support 2 weeks, 3 days ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    RESOLVED Posts
  • First I have noticed that on some posts. Then I did ‘Force regenerate thumbnails’ and cleared all cache. Now there are no featured images at all in any browser I have tried.

    Here is the screenshot of Inspect Elements. Featured image is there, but it’s not visible. And note this strange line under the second sentence.

    It is the same on every post.

    Can you please help?

     

    My URL is:  https://igrastaklenihperlica.rs/

     

    Attachments:
    You must be logged in to view attached files.

    Hi @dellgirl,

     

    I hope you are well today and thank you for your question.

     

    I am not sure why this is happening on your site but you can resolve it by adding the following CSS code in the Custom CSS code option of your theme on the below path.

     

    Admin Area -> Appearance -> Theme Settings -> Custom Code -> CSS Code

     

    .single-post article .post-thumbnail {
        display: block;
    }
    
    .single-post .post-switch {
        border-top: 0;
    }

     

    Best regards,
    Shufflehound team

    Thanks, that did help for default blog type.

    But posts with ‘Gallery’ type still don’t have featured gallery.

    Could you tell me what would be the code for the gallery type?

    This is really weird, I would like to know why this happened. Is there any connection with the solution you made for one of my previous tickets?

    This one:

    https://support.shufflehound.com/forums/topic/cropped-images-in-featured-gallery/

     

    anche io ho lo stesso problema e con il codice non succede nulla.

    Let’s find out why this is happening.

     

    Please do the below things on your site and check after every changes whether the images display fine.

     

    1. Use Gillion theme instead of the child theme.
    2. Remove custom CSS code added in the Appearance -> Theme Settings -> Custom Code -> CSS Code
    3. Remove CSS code added using Yellow Pencil Editor or disable the Yellow Pencil Editor plugin

    I found what was the problem, but why I still don’t know.

    First I did what you suggested and everything was the same.

     

    Then I looked at ‘Inspect Elements’ and realized that

    <div class=”post-type-content”>

    was inside of

    <div class=”post-item-single-container”>

     

    Then I remembered this setting:

    Theme Settings -> Posts -> Post Style:

    Standard (with title at the top) ‘ was checked. As soon as I have checked ‘Standard‘, all featured images (including galleries) were visible.

    Then I reverted all the changes I had made with theme and CSS, and still, everything was ok.

    When I switched to ‘Standard (with title at the top) ‘ featured images were gone again.

     

    Funny thing is that I don’t remember I have ever changed that setting. Maybe it was like that from the beginning, and then stop working.

    Thank you for the detailed information.

     

    I could confirm the issue on my test site, therefore, notified the theme developer about this so that it will be fixed.

     

    The issue will be fixed ASAP.

    Solution for this topic

    The issue is resolved in the below latest version of theme so please update the theme as described here https://support.shufflehound.com/updating-theme/

     


    Please login to access this file

    It is definitely resolved.

    Thanks.

    You are always welcome here 🙂

Viewing 10 posts - 1 through 10 (of 10 total)