Help! Contact form not working!

Home Forums Jevelin Theme Help! Contact form not working!

Home Forums Jevelin Theme Help! Contact form not working!

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • Help! I’ve put all the correct information into the settings section, and when I test it, the form says it’s sent an email, but nothing arrives, how can I fix it please?

    Hi @benbrickwood,

     

    I hope you are well today and thank you for your question.

     

    Please make sure that the email is not getting sent in SPAM folder.

     

    Also are you getting other emails from your site like user registration or comments made?

     

    Best regards,
    Shufflehound team

    Hi

     

    My mail is handled by Gmail, I have been to the webmail and to my desktop client and the messages are not in spam or anywhere else.

     

    My site is not a blog, I haven’t registered any new users and comments are switched off.

     

    This is really bad for my business, please can you help?

    It has nothing to do with theme actually your site is not sending emails so please resolve this issue and make sure your site is sending emails.

    You can use any of the following plugins to test it.

     

    https://wordpress.org/plugins/check-email/

    https://wordpress.org/plugins/woocommerce-email-test/

    I installed the check-email plug in, I used it to send a test email, it worked, but the main email feature on my website still doesn’t, what can I do please?

     

     

    Would you mind if i log in to your site and do some troubleshooting? If this is ok then could you please share me your site log in details privately by adding them in the box having text “Click here to share private content. Only you and forum moderators will bee able see it.”?

    Thank you!  login details supplied. Ben

    I logged in to your site and saw you are using custom email address on your site but didn’t configure contact form settings correctly as shown in the attached screenshot.

     

    Please use correct SMTP details in it and contact your host if required.

    Attachments:
    You must be logged in to view attached files.

    Hi,

    I have used the “check mail” plugin you suggested. It’s working. I have attached a screengrab of the page

     

    However, I can’t get the contact form to send. I have it on “wp-mail” Each time I test it in “settings” I get a big tick on the page, but I don’t receive any mail.

     

    I have spoken to my host, we have changed MX settings to “remote mail exchanger”

    Attachments:
    You must be logged in to view attached files.

    Please note “check mail” plugin is only for testing emails. What i said above is that you didn’t configure contact form settings correctly as shown in the attached screenshot.

     

    Please use correct SMTP details in it and contact your host if required.

    Hi, I have the same issue. Any reason why wp-mail setting would not work?

    Just answering my own comment here: in a hosted environment where email account domain is matching the site domain the email is being sent. This is only an issue in localhost, where I do my initial work, so I think we can work around that.

    Awesome great to see you got the answer.

     

    Please advise if you have more questions by creating separate topic for it.

     

    Have a fantastic day!

    Hello,

     

    I am having the same troubles above. I do not receive any test emails or any email submissions.

Viewing 14 posts - 1 through 14 (of 14 total)