Mailchimp integration with default contact form

Home Forums Jevelin Theme Mailchimp integration with default contact form

Home Forums Jevelin Theme Mailchimp integration with default contact form

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • Hi there,

    I want to collect newsletter subscribers on my home page. For that I’m currently using the default contact form as you can see in http://www.sirextiles.com. However I want this contact form to be integrated with my mailchimp account.

    Can I do it from this default contact form itself or do I need to install contact form 7 or anything like that?

    Cheers,
    Willy

    Hi Willy,

     

    I hope you are well today and thank you for your question.

     

    Yes you have to use contact form 7 plugin and to connect it to mailchimp you can use the following plugin.

     

    https://wordpress.org/plugins/contact-form-7-mailchimp-extension/

     

    Best regards,
    Shufflehound team

    I tried with the plugin you suggested, I couldn’t enable double opt in for MailChimp. So, I went ahead with Mailchimp sign up form and the opting process worked perfectly.

    Now there’s a major problem. My website is not loading. I remember when I was adding Mailchimp embedding code to “output HTML” option in Unyson, I was prompted by my security plugin that some sort of “ajax” is blacklisted and if I wanna whitelist it. That was the only way for me to go ahead. So, I whitelisted it. Now my website isn’t loading anywhere. I tried multiple browsers and it is only loading.

    HELP ME!!

    These are the ones that I whitelisted. What should I do ? Kindly help me soon

    Attachments:
    You must be logged in to view attached files.

    When I’m hiding the sign up form, site is loading properly. When I turn it back on, site doesn’t load

    I visited your site and it is loading fine for me. May be because you have removed the signup form.

     

    Can you check the JavaScript console for errors when you face this issue?

     

    In Chrome go to “Tools -> Developer Tools” and in Firefox you can go to “Tools -> Web Developer -> Console”

     

    Find information about how to open JavaScript browser console :

    http://webmasters.stackexchange.com/questions/8525/how-to-open-the-javascript-console-in-different-browsers
    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

     

    Let me know what JavaScript errors if any you are getting when you face this issue.

    Yes I am getting errors. I have attached a screenshot of it. I have enabled the sign up form so you can check it in my website. Kindly do it soon. My current visitors aren’t able to log in now

    Attachments:
    You must be logged in to view attached files.

    I visited the contact us page on your site and it is loading fine for me as shown in the attached screenshot.  Also i am not getting any javascript error message in the console.

     

    Please share the correct page URL if i am checking it in the wrong place.

    Attachments:
    You must be logged in to view attached files.

    Please look at the homepage. http://www.sirextiles.com .kindly check soon

    I don’t see the contact form on the home page of your shared site except the subscription form as shown in the attached screenshot.

     

    Please advise and if possible share the screenshot of that form.

    Attachments:
    You must be logged in to view attached files.

    BY sign up form, I meant newsletter subscription form itself(The same one you sent the screenshot of). Browser cache is enabled. SO now if you go to http://www.sirextiles.com from that same browser, you can view the site. But try visiting the site from another browser or incognito, The homepage keeps loading, but never ends.

    Please Check it up soon. My website is still down and you guys are taking way too long to respond

    I could confirm the issue on your site now.

     

    Please try clearing cache used on your site or temporary disabling it.

     

    If the issue still persists then please try temporary deactivating all plugins and see whether everything works fine and then enable the plugins one by one to see which plugin is conflicting if any.

Viewing 13 posts - 1 through 13 (of 13 total)