Theme localisation issue

Home Forums Jevelin Theme Theme localisation issue

Home Forums Jevelin Theme Theme localisation issue

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    RESOLVED Posts
  • Hi,

    I have used the .pot file you provided to translate Jevelin into Italian. I used poedit as you suggest in the documentation and generated the .po e .mo files for Italian. I added these files via FTP to the folder wp-content>languages>themes. The language of my wordpress installation is already set as Italian, but jevelin does not show the Italian translation. I tried to set the language to English and then back to Italian, but it didn’t work.

    Did I miss something?

     

    Please make sure you have also made changes in the WordPress file wp-config.php and all other steps as described in the below page.

     

    https://colorlib.com/wp/how-to-translate-wordpress-theme/

     

    Alternatively, you can translate it as suggested in the following page.

     

    https://support.shufflehound.com/theme-translation/

    Solution for this topic

    Hi,

    I solved the problem by re-naming the .po and -mo files jevelin-it_IT instead of jevelin-child-it_IT.

    Thank you.

    You are most welcome here 🙂

    Hi, I’m sorry to bother you again but I’m having some issues with the localisation.

    I have translated the .pot file and most of the text is shown translated. However, the 404 page still shows in English, as do the Portfolio category pages title (see attached screenshots).

     

    What am I doing wrong?

    Attachments:
    You must be logged in to view attached files.

    Please make sure you have translated those strings in the .pot file and generated new .mo file.

    I have translated them, generated the .mo file and uploaded it on my website /languages directory. See screenshot.

    It’s still not working.

    Attachments:
    You must be logged in to view attached files.

    Could you please share me your site URL where it’s happening?

    Thank you for your prompt reply.

    Unfortunately the website is still in development mode and cannot be freely accessed from the web. I’m attaching in a private message steps to see it in dev mode. Thank you.

    I visited your shared site and I am getting result as shown in the attached screenshot which is working fine for me.

     

    Please test it using a different browser.

    Attachments:
    You must be logged in to view attached files.

    Hi,

    the screeshot you posted is from the currently online website http://www.thelondonschool.it which is running Jevelin theme version 3.0.3.

    The one I’m talking about is still not available online, (we are migrating the website to a new hosting) and only accessible through the procedure I described above. This is running Jevelin 3.0.5. See screenshot. Can you see the menu and general look is different from the screenshot you p0sted?

     

    Thank you again for your time and patience.

    Attachments:
    You must be logged in to view attached files.

    Solution for this topic

    I found the problem. In the new website under Jevelin > Theme settings > 404 Page I didn’t change the text of the 404 page messages.

    So the .po localisation is redundant in this case.

    Thank you again.

    Awesome great to see you got that found.

     

    Please advise if you have more questions.

     

    Have a fantastic day!

Viewing 13 posts - 1 through 13 (of 13 total)