Contact Form stopped working

Home Forums Jevelin Theme Contact Form stopped working

Home Forums Jevelin Theme Contact Form stopped working

This topic contains 6 replies, has 2 voices, and was last updated by  Shufflehound Support 1 month ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • Hi,

    I am using the default contact form provided by the Jevelin Theme. It was working fine a few days ago. I don’t see any error on the screen and no success message obviously. But I do see a 404 error in the console for this file-

    /wp-content/themes/jevelin/js/form-errors.js?ver=1.0 net::ERR_ABORTED 404 (Not Found)

    When I checked the file manager, this file doesn’t exist in the JS directory. I have tried disabling all plugins etc and I don’t think theres a conflict. Its throwing an error because form-errors.js is nowhere to be found and I have no idea where it is! How can I fix this?

    Please advice. Thank you.

    Attachments:
    You must be logged in to view attached files.

    Hi @meredithn,

     

    Sorry to hear of the problem you are having.

     

    Please clear the WP-Super-Cache and temporarily disable it that you are using on your site.

     

    Please update the theme on your site to the below latest version as described here https://support.shufflehound.com/updating-theme/

     


    Please login to access this file

     

    Best regards,
    Shufflehound team

    Thanks for the info. I have updated the theme but that didn’t work. Then I tried adding a new, default contact form module back inside the page and removed the old one. I don’t know how but that is working. It’s strange coz its the same module, but one gave an error and the other does not.

    Anyways, so I got the email fine, but the success message that used to display on top of the page is not shown anymore. There is no way for the user to know that their message has been posted successfully. What could the issue be?

    Can you help?

    Thanks.

    Thanks for the info. I have updated the theme but that didn’t work. Then I tried adding a new, default contact form module back inside the page and removed the old one. I don’t know how but that is working. It’s strange coz its the same module, but one gave an error and the other does not.

    This may be because the two modules are configured differently.

    Anyways, so I got the email fine, but the success message that used to display on top of the page is not shown anymore. There is no way for the user to know that their message has been posted successfully. What could the issue be?

    Are you talking about the contact form displayed in the shared screenshot?

     

    If yes then please make sure that you have configured its Success Message as displayed in the second attached screenshot.

    Attachments:
    You must be logged in to view attached files.

    Yes. I have added all the settings correctly. I don’t see my message text. The page simply reloads after I click on the button. It used to do that before as well, but I the message was displayed on top of message. Now theres nothing. Please advice. Thanks.

    *** UPDATE ***

    I think I figured it out. Your JS code is conflicting with the WP Cache plugin. If the caching is turned off, it shows the message but if the caching setting is turned on, the message disappears.

    Any workaround for this please? I would like to use the WP Cache plugin.

    Try clearing WP Cache plugin and make sure that the WP Cache plugin is not minifying the js file by configuring its settings.

Viewing 7 posts - 1 through 7 (of 7 total)