event_id for fb pixel?

Home Forums Jevelin Theme event_id for fb pixel?

Home Forums Jevelin Theme event_id for fb pixel?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • I am a happy user of your Jevelin theme. Like many other I have installed Facebook pixel to track my website/webstore.

    Everything was good until recently I am trying to place some ad on Facebook but surprise to find out there is an issue with the pixel.

    From Facebook Data Source page shown the following problem on my website:

    ==============
    Purchase Event Missing Some Deduplication Parameters
    You’re sending Purchase events through both your pixel and the Conversions API, but they’re not being deduplicated properly because not enough of these events are receiving an event_id parameter. Event instances sent without an event_id parameter cannot be deduplicated.
    This may cause issues with the measurement of your events as well as the attribution and delivery optimization of any ad campaigns that are optimizing for this event.

    How to fix the issue
    You’ll need to use the solution below to fix the issue.
    Once you’ve fixed the issue in your website code you can mark it as resolved. This will move it to the Previously Detected section. If the issue is found again after 3 days it will move back to the Active section.
    Add an event_id parameter to all Purchase events that you’re sending from both your pixel and the Conversions API. To add an event_id parameter to the events you’re sending through the Conversions API, you can use the Payload Helper tool on the Facebook for Developers site to validate that your payload is set up correctly. To add an event_id parameter to the events you’re sending through your pixel, go into your website’s source code and add an event_id parameter to each of your Purchase event instances.

    ==================
    I have asked many people, including the developer of the plugin, Facebook for WooCommerce. They said the solution is to add the event_id to the purchase page and it could be a theme issue. Since you theme have some codes for the purchase page,  I wonder if it have another to do with you guys. I hope you can give me some direction to fix the issue. Thanks.

    P.S. I am running Jevelin 3.3

    Elton

    • This topic was modified 2 weeks, 1 day ago by greenbulb.
    Attachments:
    You must be logged in to view attached files.

    Hi Elton,

     

    I hope you are well today and thank you for your question.

     

    Could you please try updating the theme to the below latest version and also update the WooCommerce plugin?

     


    Please login to access this file

     

    Please clear and temporarily deactivate the hummingbird cache plugin that you are using on your website.

     

    Best regards,
    Shufflehound team

Viewing 2 posts - 1 through 2 (of 2 total)