Bold Font Not Working

Home Forums Jevelin Theme Bold Font Not Working

Home Forums Jevelin Theme Bold Font Not Working

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
  • dereksieb
    Participant

    Hello,

    So I just finished upgrading to Redux. Now I am having an issue with bold fonts. Nothing that is supposed to be bold using my body font “Roboto” is displaying bold. My navigation header should be bold, as well as my buttons. Also, I have body text on most pages that have bold words or sentences, and it even shows the strong tag on inspection, however, it still doesn’t display the text bold.

    I have shared my site in the private field. The navigation bar and the buttons throughout the page should all be bold. Also the “message me” and the phone number in the footer should be bold.

    I also shared an example page with body text that has strong tags not working. The first sentence of the page should be bold. If you inspect, you can even see the strong tags. However, it’s not displaying bold.

    What do you suggest I do about this?

    Thank you!

    dereksieb
    Participant

    More Context:

    I’ve been trying to fix this and I notice if I don’t have a body font selected in theme settings, and leave it blank, my bold text works again throughout the website, but it’s the wrong font. I’m not sure what font it is, I guess the theme default font? Then when I select a font again, my bold text doesn’t work again. Maybe it’s a bug? Not sure what to do here. Please help.

    Thanks!

    Attachments:
    You must be logged in to view attached files.

    dereksieb
    Participant

    It’s been 6 days since I posted this ticket. Can you please help me?

    Shufflehound
    Moderator

    Hi there,

     

    The default font might be the Roboto.

     

    Currently, it’s challenging to determine the exact cause of the issue. Would it be possible for us to log in to your website for a closer inspection? If so, please enter your login details in the private information field.

     

    Best regards,

    Shufflehound Team

    dereksieb
    Participant

    I have added you as a user and the login details are provided in the private field.

    I have also attached two screenshots for you to understand exactly what I’m talking about. All the font on the entire site that is supposed to be bold, is not displaying bold.

    Attachments:
    You must be logged in to view attached files.

    dereksieb
    Participant

    Shufflehound support used to be fast, now it takes a week to get a reply. What happened? I have included screenshots and my login info in the last post. Please help me.

    dereksieb
    Participant

    Another update: Now, all google fonts are missing from the font list in theme settings > styling. It only shows “standard” fonts and even those don’t work when selected. Bold words are now showing bold when no font is selected, but it’s not the font I want to use. Please help me.

    Shufflehound
    Moderator

    Hi there,

     

    Thank you for providing the login details.

     

    Regarding the bold issue, we couldn’t replicate it on either Windows or MacOS. It was also working fine on both Chrome and Safari. We have attached a screenshot below. Please check it on multiple browsers and devices. A known issue is that if you have a font, such as the one used on the website, installed on your device, it could cause compatibility issues.

     

    As for the missing Google fonts issue, we found that when we tried to install a debugging plugin, we received the error “Installation failed: Download failed. cURL error 77.” It seems that there may be some issues with your server/hosting that could be related to why the Google fonts are missing. So we recommend contacting your hosting support.

     

    Best regards,

    Shufflehound Team

    dereksieb
    Participant

    Please read through my whole thread. I have explained everything. It’s been so long with this ticket. Please take the time to fix it. This is a MAJOR issue with your theme. I don’t see a screenshot attached. As I stated, the bold font is displaying now, without a font being selected in my theme settings. Before all my fonts disappeared, I had roboto selected as the body font, and that was causing the bold issues. Why would all of a sudden the fonts disappear? I’ve had google fonts all this time until now, then it stops working when I upgrade to redux. Yes I have tight permissions with my hosting, but no issues. I can download any plugin manually. What would I tell my hosting support? Google fonts should be included with your theme, right? You haven’t given my any help or solutions to this MAJOR issue and this is getting ridiculous with you giving me a half ass response every 10 days. PLEASE FIX THIS.

    dereksieb
    Participant

    More context: “Installation failed: Download failed. cURL error 77” is the same error I got recently when trying to update my Redux plugin. However, as you suggested, I was able to manually download and install it in my CP. Do you need me to install a debugging plugin manually? I’ve never had these issues until upgrading to Redux. Where are the fonts included with your theme located? Is it possible for me to manually download and install the fonts in my hosting CP? Again, please read this whole thread before giving me a quick half-ass response again, I’ve been waiting for over half a month and now this is just ridiculous.

    Shufflehound
    Moderator

    Sorry for that, we have attached the screenshots again.

     

    The Redux framework updates fonts via their servers periodically to keep Google fonts updated. It seems that when you installed the plugin, it showed their included fonts, but later it tried to update them via their servers and failed. Unfortunately, we don’t have any tips on how to solve this other than by fixing the underlying issue with cURL.

     

    Besides that, the bold font on your website currently works fine on all our devices.

    • This reply was modified 6 months, 3 weeks ago by Shufflehound.
    • This reply was modified 6 months, 3 weeks ago by Shufflehound.
    Attachments:
    You must be logged in to view attached files.

    dereksieb
    Participant

    Your screenshots are showing the wrong font. I need roboto as my body font, and montserrat as my heading. Please fix my fonts so body is roboto and montserrat is my heading. All fonts are currently missing from my theme settings. How do I get the fonts back? There is no option to update font, or update the redux plugin. Again, there is no issue with my cURL. I can manually install any plugin. So what do I need to do?

    dereksieb
    Participant

    Update: (READ ENTIRE MESSAGE) Today, the google fonts are appearing again in my theme options settings. I have set roboto as body and montserrat as heading. Now, you can see that the bold font problem is back, so we’re back to the original problem in the thread. Please check again and you will see it looks again like my screenshots provided in the previous message. My hosting provider said there’s no problems with the hosting and he’s never had this issue and neither have any other developers he is hosting for, so the problem is with your theme. Please advise.

    Shufflehound
    Moderator

    As Google fonts appeared in the settings, we could adjust some options.

     

    Is it better now?

    • This reply was modified 6 months, 3 weeks ago by Shufflehound.
    • This reply was modified 6 months, 3 weeks ago by Shufflehound.

    dereksieb
    Participant

    It appears to be working now! Can you tell me exactly what you adjusted so I know what the problem was in case it happens again?

    Shufflehound
    Moderator

    Certainly! In the Jevelin Settings > Styling section, we entered an additional font weight for “Additional Font 1” (at the bottom of the page).

     

    The problem was that the bold font weight for the Roboto font wasn’t chosen in the theme settings, and as a result, the theme didn’t load it. This is for optimization purposes, as some fonts can have up to 9 different font weights, which could potentially slow down the loading speed.

    dereksieb
    Participant

    Cool. Well I guess we’re all good for now. Thank you for the fast responses today, and for finding a solution. I really appreciate it!

    Shufflehound
    Moderator

    You are welcome! 🙂

Viewing 18 posts - 1 through 18 (of 18 total)