Custom footer template not working

Home Forums Jevelin Theme Custom footer template not working

Home Forums Jevelin Theme Custom footer template not working

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    RESOLVED Posts
  • mktciss
    Participant

    I created a custom footer template using the WPBakery builder.
    When I choose my custom footer in theme settings > footer, it is not applied, only the default footer appears.
    I already tried disabling the footer widgets, changing the number of columns and none of the options made my custom footer be added to the site.

    Attachments:
    You must be logged in to view attached files.

    Shufflehound
    Moderator

    Hi there,

     

    Does the footer not function correctly on all pages or only some of them?

    We asking that, because it is possible to manually overwrite the settings for each page and post.

     

    Best regards,

    Shufflehound team

    mktciss
    Participant

    Footer does not work on all pages.
    Only the theme’s default footer with widgets works.

    I also tried replacing manually on the page but that didn’t work either.

    Shufflehound
    Moderator

    Oh, then would it be possible for us to log in to your website, so we can inspect this issue further? (you can share it in the private information field below)

    mktciss
    Participant

    Yes, please do this.

    Shufflehound
    Moderator

    Hi there,

     

    It seems that the footer now appears on all the pages.

     

    Can you please take a look? 🙂

     

    Best regards,

    Shufflehound team

    • This reply was modified 1 month, 2 weeks ago by Shufflehound.

    mktciss
    Participant

    Hello,

    The footer that is appearing on all pages is just the HTML registered in the footer widgets. Appearance > Widgets > Footer Widgets. In the theme’s footer settings it appears with the name Default (from theme settings).

     

    The footer that I want to appear on all pages is the My Custom Footer (From WPbakery page builder) selected in Jevelin > Theme Settings > Footer: Footer Template as per the image I sent you before.
    My Custom Footer was created as a post type shufflehound_footer in the Footers menu.

     

    In theme customization I select the Footer Template (My Custom Footer) and no footer appears on the pages.

    • This reply was modified 1 month, 2 weeks ago by mktciss.
    Attachments:
    You must be logged in to view attached files.

    Shufflehound
    Moderator

    Hi there,

     

    Oh, would it be possible to test it again?

    Currently, it seems the login details aren’t working anymore.

     

    Best regards,

    Shufflehound team

    mktciss
    Participant

    Login updated

     

    mktciss
    Participant

    Any solution?
    I’ve had this problem for two weeks now.

    I tested it in another development environment with all plugins disabled and the problem remains, the custom footer is not loaded.

    mktciss
    Participant

    Hi,

    Any news on this case?

    Shufflehound
    Moderator

    Hi there,

     

    Yes, we finally found the issue: your child theme has an old footer.php version that overwrites our new footer.php file.

    The solution is to just remove footer.php file from jevelin-child theme or to change its content to the new version.

     

    Best regards,

    Shufflehound team

    mktciss
    Participant

    Hi there,

     

    Thanks a lot, I removed the footer.php file from the child theme and it worked, now the custom template is showing. The file was created in an old version of the theme.

    But now the Copyright Bar does not appear when the custom template is active. The slash only works with the default footer.

     

    Thanks !

     

    Shufflehound
    Moderator

    That is great! 🙂

     

    Can you please try to fully disable the child theme and see if that works?

    mktciss
    Participant

    Hi there,

    I disabled the child theme and the Copyright Bar still doesn’t appear when Custom Footer is enabled.

    I cleared the page and css caches and it didn’t show up either.

    If I choose the Footer Template Default (from theme settings) the Copyright Bar works normally.

     

    Best regards,

    Shufflehound
    Moderator

    Oh, after some debugging it seems that we understood the issue.

    The copyright bar isn’t meant to be working when activating the custom footer as you can just create a new section inside it and add copyrights in that way. As it gives you full control over the content you are displaying.

    mktciss
    Participant

    Ok, I got it.

    I will create the bar along with the custom footer.

     

    Thanks for the support.

    Shufflehound
    Moderator

    You are welcome! 🙂

Viewing 18 posts - 1 through 18 (of 18 total)