Replace "[time] ago" with the actual time

Home Forums Gillion Theme Replace "[time] ago" with the actual time

Home Forums Gillion Theme Replace "[time] ago" with the actual time

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    RESOLVED Posts
  • Hello,


    I would like to know how to replace the “7 months ago” (or whatever time is that) phrase that appears near every post title with the actual time, in a format like “15th September 2017 Β· 6:30 pm” or “15/09/2017”, and also how to get rid of the “1 min read” phrase (or at least how to translate it into my language, i.e., Italian).


    Thank you a lot,



    Hi Stefano,


    Thank you for your question.


    To achieve this, you have to develop custom code in the child theme of Gillion theme.


    Developing custom code for custom functionality is beyond the scope of support that we provide here.


    If you are not a developer then you can consider hiring a developer to develop it for you. You can hire a developer from any freelance site. Shufflehound recommends the developer


    Best regards,
    Shufflehound team

    Got it. However, please consider about adding an option in the future to let the user decide about the format of such field. It is weird for a blog to have dates like “5 years ago” instead of something like “6th March 2013”.


    Thank you,



    We have created a feature request for it so that the option will be developed in the future version of theme.



    Thank you a lot.

    You are most welcome here πŸ™‚

    If anyone is interested, here’s the way to do the trick:


    navigate to:

    Appearance > Editor > Select theme to edit (select Gilion) > inc > helpers_blog.php


    “helpers_blog.php” is the file that contains the code for the date format.


    Look for any line that looks like:


    <?php echo human_time_diff( get_the_time(‘U’), current_time(‘timestamp’) ) . ‘ ‘ . esc_html__( ‘ago’, ‘gillion’ ); ?>


    and replace it with:


    <?php echo ( get_the_date() ); ?>


    The only problem is that this works for the parent theme but not in the child theme, so you have to modify the file everytime Gillion gets an update.

    Thanks for helping out here in this forum by sharing the solution.


    Your help here is really appreciated.

    You’re welcome! πŸ˜‰

    Solution for this topic

    The feature request is implemented in the below latest version of theme so please update the theme as described hereΒ


    Please login to access this file

    Great! Yes, I updated it a couple of days ago. Thank you!


    You are always welcome here πŸ™‚

Viewing 13 posts - 1 through 13 (of 13 total)